Error TLS 1.2 while opening Quickbooks

While opening QuickBooks I am getting error “This version of QuickBooks requires TLS 1.2 for secure communication”.  What should I do?

Asked on June 12, 2018 in Error Messages.
1 Answer(s)

We were having this issue with few of our computers after we updated QuickBooks. This occurs due to a security setting with Internet Explorer. Since Microsoft has recently launched some major security updates they have made TLS 1.2 mandatory for some applications, you can change the settings by following the below steps:

Allow TLS 1.2 in Internet Options

  1. Go to Internet Options
  2. Click on Advanced Tab
  3. Check the option “Use TLS 1.2

Run QuickBooks as Administrator

  1. You need to right click on QuickBooks Desktop Icon and click on Properties
  2. Go to the Compatibility Tab on the top
  3. Check the box “Run this Program as Administrator.”
  4. Click OK

 

The above steps should be able to solve your issue.

Answered on June 16, 2018.

Your Answer

By posting your answer, you agree to the privacy policy and terms of service.